Excel

Aus Marketing United
Wechseln zu:Navigation, Suche

Excel ist ein nützliches Tabellenkalkulations-Programm von Microsoft. Es ist Bestandteil des Microsoft Office-Pakets.

In diesem Artikel erhältst du Tipps und Tricks, wie du Excel besser bedienen kannst.

1 Excel-Tipps

1.1 Formeln

  • Addieren ganzer Spalten oder Zeilen:
    Für eine Spalte: =SUMME(A:A)
    Für eine Zeile: =SUMME(1:1)
    Man muss also immer die entsprechende Spalte oder Zeile doppelt nennen.
    Wichtig dabei: Die Zelle mit der Summenformel darf sich nicht in der zu summierenden Zeile oder Spalte befinden, sonst gibt es einen Zirkelbezug mit dem Excel nicht klarkommt.
  • Prüfen ob eine Zelle leer ist
    =ISTLEER(B2)
    Die Funktion gibt WAHR oder FALSCH aus.
  • Mache etwas wenn die Zelle (nicht) leer ist:
    =WENN(ISTLEER(B2);"";B2+C2)
    Gibt nichts aus, wenn B2 leer ist, ansonsten wird eine Summe berechnet.
  • Summe wenn Zellen nicht leer sind:
    Dies lässt sich mit dem Suchkriterium "<>" realisieren. Beispiel: =SUMMEWENN(C2:C5;"<>";B2:B5)
  • Summe wenn Zellen ein bestimmtes Wort enthalten:
    Dies kannst du mit einem Sternchen * hinter dem zu suchenden Wort erreichen. Beispiel: =SUMMEWENN(C2:C5;"Firmenname*";B2:B5)
  • Zielwert zum heutigen Zeitpunkt abhängig von Jahreszielwert:
    =(HEUTE()-DATWERT("1.1.2019"))/365*J4, wobei J4 die Zelle mit dem Jahreszielwert ist
  • 'Ergebnis auf 0 beschränken beziehungsweise nicht negativ werden lassen:
    =max(0;A1)
  • Ergebnis nicht größer als x werden lassen:
    =min(x;A1)
  • Logische Funktionen (UND, NICHT, etc.)

1.2 Bedingte Formatierungen

  • Workaround um einen relativen Bezug in einer bedingten Formatierung zu erlauben:
    Namensbereich definieren, dort das $ vor der Zeile entfernen und dann in der bedingten Formatierung den Namensbereich eintippen [1]
  • Um eine 3 Stufen-Skala bei Prozentangaben wirklich von rot (0 %) bis grün (100 %) laufen zu lassen:
    In den Stufen jeweils "Zahl" einstellen und die Zahlen auf 0, 0,5 und 1 setzen.
  • Zellen hervorheben, deren Wert in einem anderen Bereich vorkommt:
    Bedingte Formatierung mit der Formel =VERGLEICH(A2;C:C;0) (wobei die Spalte C in diesem Fall der "andere Bereich" ist)[2]
  • Zellen hervorheben, die leer sind:
    Entsprechende Zellen markieren. Bedingte Formatierung mit der Formel =ISTLEER(A1). Anstelle der Zelladresse A1 die Adresse der ersten markierten Zelle nehmen.

1.3 Zeitumrechnungen

  • Zahl in hh:mm umwandeln:
    =ZEIT(Stunden;Minuten;Sekunden)
    Beispiel um 1234 Minuten in hh:mm umzuwandeln: =ZEIT(0;1234;0)
  • Minuten umrechnen in hh:mm:
    In der Zielzelle folgende Formel nutzen:=A1/24/60
    Dann die Formatierung der Zielzelle auf "Benutzerdefiniert" -> "hh:mm" stellen
  • hh:mm umrechnen in Dezimalzahl:
    In der Zielzelle folgende Formel nutzen:=A1*24
    Falls nötig die Zelle noch auf die Standardformatierung setzen.

1.4 Sonstiges

  • Zeilen gruppieren um Bereiche ein- und ausklappen zu können:
    Zeilen markieren, dann unter "Daten --> Gruppierung und Gliederung" Gruppierung anklicken.
  • In Suchausdrücken nach einem Teil eines Wortes suchen.
    Im Ausdruck ein Sternchen (*) verwenden.
    Beispiel: geld* findet alle Wörter die mit "geld" anfangen - also zum Beispiel auch "geld verdienen"
  • Zellen teilen mit Trennzeichen:
    Zu trennende Daten markieren, dann unter "Daten" -> "Text in Spalten" wählen. Umständlichere Lösung (anstelle von "A1" muss es in der zweiten Formel "A2" heißen)
  • Zellen mit relativen Bezügen exakt kopieren: Zu kopierende Zellen markieren, Strg H (Ersetzen): "=" durch "§" ersetzen (dadurch interpretiere Excel den Inhalt als Text), Zellen kopieren, dann die kopierten Zellen und die Originalzellen markieren und "§" zurückersetzen mit "=" [3]
  • Falls man keine "Werte einfügen" kann, kann es daran liegen, dass man andere Zellen ausgeschnitten hat. Die anderen Zellen zu kopieren, kann funktionieren.
  • Um Text und Formeln innerhalb einer Zelle zu verbinden:
    Stelle den Text in Hochkommas und füge vor der Formel & ein[4]. Beispiel:
    ="Text: "&SUMME(A:A)
  • Wenn es beim Öffnen von csv-Dateien Probleme mit Umlauten und Sonderzeichen gibt:
    Öffne die csv-Datei nicht über Doppelklick, sondern gehe in Excel auf Daten -> Aus Text. Wähle dort dann als Zeichensatz UTF-8 (weit unten bei "U").
    Wie du den Standard-Zeichensatz beim Importieren dauerhaft änderst, wird hier beschrieben.
  • Häufigkeiten in Excel grafisch anzeigen (mit PivotTable): [1]
  • Spalten zusammenführen: Neue Spalte machen, dort in erste Zelle =A1&" "&B1 einfügen (um Spalte A und B mit Leerzeichen miteinander zu verbinden). Dann auf die Zelle unten rechts doppelklicken um die restlichen Zellen nach dem gleichen Schema zu füllen. Wenn eine der Spalten ein Datum enthält, kannst du in die Zusammenführungs-Zelle zum Beispiel Folgendes schreiben, damit das Datum auch dort korrekt angezeigt wird: =TEXT(A1;"T.M.")&" bis "&TEXT(B1;"T.M.")

2 Shortcuts

  • Zwischen Blättern wechseln: Strg Bild-auf, Strg Bild-ab
  • Kommentar hinzufügen: Strg F2

3 Excel-Weblinks

4 Weiterführendes

                   

4.1 Weblinks


Autoren

Jeder Autor hat seine eigenen Passagen zu diesem Artikel beigesteuert. Deshalb muss nicht jeder Autor alle Passagen des Artikels unterstützen.
Zahl in Klammern = Anzahl der Artikel-Bearbeitungen dieses Autors. Eine hohe Anzahl bedeutet nicht zwangsweise, dass dieser Autor auch viel Inhalt zum Artikel beigesteuert hat.

Online-Marketing-Quiz
Erzähl's weiter:
Was sagst du zu diesem Thema?